La función Si en Excel evalúa una condición. Si el resultado de la condición es “Verdadero” realizará una tarea si es falso realizará otra tarea.

Función Si en Excel. Funciones condicionales.

Función Si en Excel. Para qué sirve.


La función Si en Excel evalúa una condición si el resultado de esta evaluación es “Verdadero” entonces realizará una tarea. Sin embargo si el resultado de la evaluación es falso entonces realizará otra tarea diferente. Esta función pertenece a la familia de funciones lógicas. Si el precio de una determinada acción baja un 5% con respecto a un precio de compra determinado entonces realizaremos una venta del valor bursátil.

La función Si en Excel evalúa una condición. Si el resultado de la condición es “Verdadero” realizará una tarea si es falso realizará otra tarea.

Es importante conocer determinados operadores en Excel para poder construir la función condicional “Si”.

La función Si en Excel evalúa una condición. Si el resultado de la condición es “Verdadero” realizará una tarea si es falso realizará otra tarea.

Argumentos de la función.


La función si admite tres argumentos. El primero es estrictamente obligatorio y el resultado de la función si no se utilizan los otros dos argumentos entonces será “TRUE”/“VERDADERO” o “FALSE”/”FALSO”

Comprobación_lógica: Realiza una comprobación que como resultado me devolverá un “Verdadero” o un “Falso”

Valor_si_verdadero: Acciones que queremos desencadenar en caso de cumplirse la condición. Puede ser un mensaje de texto que introduciremos entre comillas o la llamada a otra función o un cálculo.

Valor_si_falso: Acciones que queremos desencadenar en caso de NO cumplirse la condición. Puede ser un mensaje de texto que introduciremos entre comillas o la llamada a otra función o un cálculo.

Ejemplo de uso de la función Si.


Volvemos al ejemplo anterior. Tenemos una inversión sobre un determinado valor bursátil “Acme SA”. Sabemos que las acciones se compraron al precio de 10€. Además tenemos marcados los siguientes objetivos:

  • Si el valor supera en un 10% el precio de compra lo venderemos para ganar un margen.
  • Si el valor pierde un 5% con respecto al precio de compra lo venderemos para minimizar la pérdida.

Con estas premisas se realiza un chequeo diario de los valores bursátiles para conocer su precio de cierre y evaluar el resultado de nuestra inversión y así poder mediante la condición “SI” tomar una decisión.

El análisis inicial será el siguiente:

La función Si en Excel evalúa una condición. Si el resultado de la condición es “Verdadero” realizará una tarea si es falso realizará otra tarea.

El resultado esperado debe ser una tabla como la que se muestra a continuación. En donde aquellas cifras que cumplan la condición desencadenan un mensaje o bien de venta por beneficio o bien de venta por pérdida.

La función Si en Excel evalúa una condición. Si el resultado de la condición es “Verdadero” realizará una tarea si es falso realizará otra tarea.

En este caso  “anidaremos” una función Si dentro de otra función Si. Anidar una función dentro de otra significa que uno de los argumentos del Si inicial será otra función Si.

SI( Prueba lógica; “Valor si se cumple”; “Valor si no se cumple”). Valor si no se cumple = SI(Prueba lógica; “Valor si se cumple”; ”Valor si no se cumple”)

Si (Prueba lógica; Valor si se cumple;SI(Prueba lógica;Valor si se cumple;Valor si no se cumple)

Y traducido con nuestras condiciones podemos escribir lo siguiente:

Si(Precio de cierre >= 10€+10€*10%; “Venta por Beneficio”;SI(Precio de cierre <= 10€ – 10€*5%; “Venta por pérdida”;”Mantener”))

Traducido en Excel tenemos la siguiente expresión:

=SI(E2<=C2-(C2*5%);"Vender por pérdida";SI(E2>=C2+(C2*10%);"Vender por Beneficio";"Mantener"))

La función Si en Excel evalúa una condición. Si el resultado de la condición es “Verdadero” realizará una tarea si es falso realizará otra tarea.

Función Si en inglés


La función Si en inglés se denomina

IF (Logical_test;Value_if_true;Value_if_false)

 

Descarga el ejemplo de uso de la función Si.


Puedes descargar el ejemplo aquí:

Función-Si-en-Excel

comprobar, condición, condicional, función lógica, función si, IF, IF function, prueba lógica, SI, valor si


Iván Antona

Especialista formación Microsoft Excel en Madrid para empresas.

Cursos Excel Empresas Tecnoexcel

Contactar

Calle de Gloria Fuertes, 10

28701 San Sebastián de los Reyes

Madrid, España

+34 911 23 52 43

ivan.antona@tecnoexcel.es


TecnoExcel | Cursos Excel para empresas